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Cadence Tutorial

The following Cadence CAD tools will be used in this tutorial:
* Virtuoso Schematic for schematic capture.

* Spectre for simulation.
We will practice using CADENCE with a CMOS Inverter: creating (1) Schematic (2) Simulation

Computer Account Setup

Please see the Unix/Linux command_before doing this new tutorial.

YOU SHOULD HAVE YOUR ENVIRONMENT SET UP FOR CADENCE AND
ADDITIONAL TOOLS

Running the Cadence tools

Log in to your UNIX/LINUX account. Open the terminal window.

Now you should be able to run the Cadence tools. Never run Cadence from your root directory, it
creates many extra files that will clutter your root. Instead please create a directory (e.g.
cadence).

>> mkdir cadence

>>cd cadence

Now start Cadence by typing
>>csh

>> source cshrc

>>cd cadence_ms_labs_613

>>VIrtuoso

Please see the Fig. 1 for above command.
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[TE] Red Hat Enterprise Linux 5 -
Player + | g ~ & = T <«
ﬂ Applications Places 5System % 9 8:04 PM @Jﬂ |

root@localhost:~/cadence

File Edit Miew Terminal Tabs Help

[root@localhost ~]# cd cadence/ |5
[root@localhost cadencel# csh

[root@localhost ~/cadence]# source cshrc

Welcome to Cadence tools

[root@localhost ~/cadence]# cd cadence_ms_labs 613
[root@localhost cadence ms labs 613]1# virtuosol

Fig. 1 Terminal window

The command will start Cadence and after a while you should get a window with the
“Virtuoso@ 6.1.5, also called Command Interpreter Window (CIW) as below: Fig 2

" Virtuoso® 6.1.5 - Log: /root/CDS.log =l

File Tools Options Help cadence

Loading sch¥Wiew. cxt
Loading selectSw. cxt
Loading L¥S. cxt
Loading layerProc. cxt
Loading =1UI. cxt
Loading auGore. cxt
Loading dcm. cxt
Loading vhdl. cxt
Loading seismic. cxt
Loading ci.cxt
Loading ams. cxt
Wirtuoso Framework License (111} was checked out successfully. Total checkout time was 1.52s.

[

nmouse L I F:

1] > [

Fig. 2 Cadence virtuoso (CIW) window
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For more information on the various Cadence tools I encourage you to read the corresponding
user manuals. You can get to the manuals by pressing Help -> Virtuoso Documentation on any
Cadence window (e.g. CIW)

Now we need to create a new library (to contain your circuits) so from the Virtuoso (Fig 2)
Command Interpreter Window (CIW) go to File -> New -> Library from the File menu. You
will see a “New Library” window (Fig 3). Fill in the name of the new library (e.g.
CMOSInverter) in the dialog window (this will create the library in the directory where you
started “Virtuoso”, you could also choose to set a path if you wanted another directory). Click on
“Attach to existing tech library” and click OK.

|'-- New Library x|
Library Technology File
MHame CMOSInwerter w Compile an &SCI technology file

Directory (nor-library directaries) . Reference existing technology libraries

. & Attach to an existing technology library
DRCrun B : :

ERD — Do not need process information

LVs

bhanul

bpLogs = Ciesign Manager: Mo DR

daiict —

aotSeadence foadence _ms_ labs B13

m Cancel Crefaults Spply Help

Fig. 3 New Library Window

The above steps can be also performed using the Library Manager. After you start Cadence and
get the “Virtuoso CIW” window, go to Tools->Library Manager or press F6 on keyboard. It
will open the Library Manager window (Fig 4) as shown below. You can create the new library
(CMOSInverter) from the Library Manager following the same steps as explained above. Now
the “CMOSInverter” library should appear in the Library Manager window. It is easier to work
with Library Manager. However, for this document we will work through Virtuoso- CIW
window.

Let's start our first schematic now!
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SCHEMATIC CAPTURE

In the Virtuoso CIW window go to File -> New -> Cell View. You will get a “Create New file”
window (Fig 4). Fill in the information in the dialogue window as below and then press OK.
Library Name : CMOSInverter
Cell Name : myinverter (you can choose other name if you want)
View Name : Schematic
Tool : Composer-schematic

File

Library CrOSInyerter n
Cell nylnwerter

e schematic
Type schematic n
Application

Cpen with Schematics L n

_ Abwvays use this application for this type of file

Likwrary path file
frootfcadence fcadence ms labs 613/cds. 1ib

Cancel Help

Fig 4 Create New File window

Wait for a while. “The schematic window will appear. You should get the “Virtuoso Schematic
Editing” window as shown below (Fig 5). Spend some time analyzing the window. On the left
side you have various shortcuts to common used commands such as: placing component
instances (looks like an IC), drawing wires, placing ports, stretching, copying, zooming in and
out, saving, etc. If you pass the mouse pointer on top of the buttons you get short pop-up help
messages. You also have access to these commands (and others) from the menu. It is not possible
here to describe all the functionality of Virtuoso Schematic so you are strongly encouraged to
read the on-line user manuals.

You should notice that the top bar of the window will display the name of the library
(CMOSInverter), cellview (myinverter) and schematic at the end.
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Fig 5 Virtuoso Schematic Editing window (Composer)

Let's start our first schematic to create the CMOS Inverter. Expand the Virtuoso Schematic
Editing window if necessary. We will pace the NMOS and PMOS transistors on the schematic.

Placing Instances

Click on the “Instance” button (icon) on the left side (which looks somewhat like an IC, or go to
Add -> Instance), this will pop-up an “Add Instance” window (Fig 6).
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@ Virtuoso® Schematic Editor L Editing: CMOSInverter myinverter schematic |_|E|[>EJ1
Launch FEile Edit W¥iew Create Check Options Migrate Window Help CédEl’I(E
U B R l® D Mm% QTR s ¢ -7 7 IR |1 »
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Q - n - | Library | _Browse R
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Fig 6 Add Instance Window

Now click on the Browse. Another window called “Library Browser — Add Instance” (Fig 6) will
pop up. We will select PMOS transistor and will place it on the Virtuoso Schematic window.
Follow the steps now. Select as follows in the Library Browser window (Fig 7).

Library =>gpdk180

Cell => pmos

View => symbol
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Library Browser - Add Instance
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Fig. 7 Library Browser window

Change following properties of pmos in “Add instance” as given here.

Names => M1
Width =>800 nm
Length => 180 nm

Similarly, now we will place the NMOS transistor. Go back to the “Library Browser-Add
Instance” by left clicking on this window. Select as follows:

Library =>gpdk180
Cell => nmos
View => symbol
Notice carefully. You need to select “nmos’ under the cell for NMOS.

Now click on the “Add Instance” window. Change following properties of the nmos in the “Add
instance” window.

Names => M2, Width => 360 nm, Length => 180 nm
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Ok, you have NMOS and PMOS on your schematic. So far so good!!!!

To change the parameters of the instance, select the instance (by clicking on it with the mouse)

6 2

and then use “properties” icon or press “q’.

Now we also need to add wires, I/O pins and power supply.

First let’s add wires (narrow) to connect transistor’s terminals and form a schematic of the
CMOS Inverter.

: CMOSInverter myinverter schematic il x|
Launch Eile Edit ¥iew Create Check Options Migrate Window Help CédEl’I(E

o B RE 0 EX e To s e -7 r R &’ % L -
- - |[#arkspace: |Basic n':E\u [ My :Jﬁ [N 1 T; | s [l o n -

| Havigator Al x|
" Default B
a B-

Mame i
= myinverter
- () WD (nmos)
e () PO (praos)
Property Editor 7E X

S . S|

mauze L:

Fig 8 NMOS and PMOS on schematic

Connecting Wires

To connect the wires, click on the icon “Wire (narrow)” on the left side. You will see an “add
Wire” window. You can choose the color whatever you want to. Now activate the Virtuoso
Schematic Editing window by clicking on its title bar.

Move the mouse over or click on the s key on your keyboard. This snaps the wires to connect
between the little diamond-shapes displaying by the nodes. You can click on the node (diamond-
shape) with left mouse button, move the mouse over (you will see wire attached) and then double
click at other end to connect wire between those points. Connect all the wires likewise. When
you are done hit “Esc” on the keyboard. You can delete unwanted wires if connected
accidentally. To delete the wire, select that wire by left mouse click and then hit Delete on the
keyboard.
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See Fig 9
Virtuoso® Schematic Editor L Editing: CMOSInverter myinverter schematic
Launch File Edit Miew Create Check Options Migrate Window Help cédence
Ui dd[$ 0 @XOTEs ¢ -7 ¥ |[QAQKLAQHI%H 1L »
- - workspace: |Basic n = l“=='|o s :ﬁ l% Y T; | a% Qr n -
| Navigator 7 & x| - - -

7 Default n o
pras
Q n - . O
Mame | -
= myinverter
fe (©) MM (nmos)
(2D PMO (pmos)

Property Editor 78X

JE

maousge L I R:

Fig 9 CMOS with no pins

Let’s connect the I/O pins now.
Adding Pins

To add the input and output pins, click on the “Pin” icon at the lower left corner. The “Add
Pin” form appears.

Under the Pin Name type Vin. Note that Direction in the form reads input, as shown below
(Fig 10).

10
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=1 1:13An

s

Fig 11 CMOS with pin, gnd and supply (Vdd)

The final schematic should look somewhat like this (Fig 17). Success?

It's a good idea to save your design from time to time in case the system crashes.

Everything worked fine so far!!!! Congratulation!!!

Check and Save your design

Now you need to Check and Save your design (either click the top left button or go to Design ->
Check and Save). Make sure you look at the “Virtuoso” CIW window and there are no errors or
warnings, if there are any you have to go back and fix them!

The Virtuoso window will give the message as shown below.
“Schematic” check completed with no errors.

“CMOS Inverter myinverter schematic” saved.

11
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Let’s now perform the simulation on the inverter circuit to see the final results!!!

In the Virtuoso Schematic window go to Launch - ADE L
Then you will get the simulation window or ADE pop-up window

Please see Fig. 12.

Tools -> Analog Environment. You will get “Virtuoso Analog Design Environment (1)” window
(Fig 12).

In the Virtuoso Analog Design Environment, go to “Setup -> Model Libraries.........

BE Virtuoso® Analog Design Environment L Editing: CMOSIinverter myinverter schematic E]@E]
Launch File Edit Yiew Create Check Options Migrate Window Help _cadence
. . N - T
Launch Session  Setup  Analyses Variables Outputs  Simulation  Results Tools Help cadence [+] |
Bl laksdb 0
fnal 7 x| =
Design Yariahles boiied —_— At
Type | Enahle| Arguments B=.
Mame | Walue | @
h b
®
Outputs Zé‘.??.IO
Mame/Signal/Expr | ¥alue | Plot| Save| Sawve Options |
. Piot after sinulation: (futo  |@  Plotting moce: Replace |3
lmause L: b R: fouseFopUpg

Fig. 12 ADE Window
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Now you need to choose the type of simulation. From “Virtouso Analog Artist”( Fig 13) go to
Analyses -> Choose... ( Fig 13). In this case we will choose a transient analysis. Enter the stop
time for transient analysis. Let’s type 200p for stop time. Click OK.

Bl Virtuoso ® Analog Design Environment L Editing: CMOSInverter myinverter schematic E]@E]
Launch File Edit Miew Create Check Options Migrate Window Help cadence
Virtuoso® Analoa D on Environment (1) - CMOS|invert mviny r schematic [;]@E]
m Choosing Analyses -- Virtuoso® Analog Design E = |l
Launch Sgssion | - Iy & 2 cadence 5l ]
Analysis & tran o GC o Ac — hoise |
14, _— M-
&> &2 | § o xf _ sens _ domatch o sth i)
o NZ o 5P — envlp o 155 7EX| =
Design Variahles g —— AT
& pac _ psth o pnoise o pxf B
Name | psp gpss fpac gpnaise E
e Op=f — gpsp o hh « hhac -
— hbnoise  hbsp |t'°"
Transient &nalysis *
Stop Time 200 6
78X O
accuracy Defaults (errpresef) | Save Options |
_ conservative » moderate _ liberal VR
— Transient Moise
— Dynamic Parameter
Enahled |« Options...
= Ny - e;f{eplace n _
nmouse L: m walCELY \GLiRlaullss \BRR/ e R [MousePoplph |
000 T T . H 1

Fig 13 Choosing Analysis (Transient Analysis)

For DC analysis, please see the Fig. 14.
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Fig 14 Choosing Analysis (DC Analysis)

Now in the “Virtouso Analog Artist” (Fig 15) go to “Outputs -> to be plotted -> select on
schematic”. That will bring your inverter cell view window in front. Select node voltages by
clicking on the net. We will click on input and output nets (wires) to select input and output
voltages. The currents can be selected by clicking on the terminals (red squares).

14
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Fig. 15 ADE for Output plot
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Fig. 16 ADE after setup

Now we can finally simulate! Click on the “Netlist and Run Simulation” button (looks like a
green light) on the right or go to “Simulation -> Netlist and Run”.

9

It will start simulation. You will need to wait for a while. You should check your “Virtuoso’
window for messages while it is running the simulation.

In case you have errors you will need to go back and correct them. This can be tricky!

CAUTION Each time you change the schematic you have to do Check and Save!.

You should finally get the desired simulation results, input and output
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] CMOSinverter myinverter schematic [

DC Fesponse
MName

Min

maouse L fl: R:

Fig. 17 Simulation Results (DC analysis)

You can zoom in your waveforms.

Kl CMOsInverter myinverter schematic £

Tmansient Response

Mame

mouge L: P R:

Fig. 18 Simulation Results (Transient Analysis)
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Symbol generation
Delay Calculation (From Schematic)
Power Calculation (From Schematic)

el o e

Area Calculation (From Layout)

Lab Assignment: #2

Design and simulate a 2-input NAND gate. Calculate the area, power, current, and Delay.

Good Luck
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